ブログ

割とコンピュータよりの情報をお届けします。

statnett/vue-plotlyでWebGLをサポートしていないような表示が出る問題

昨日のとある作業で,statnett/vue-plotlyでWebGLをサポートしていないような表示が出る問題が発生して作業が止まってしまった。
"Webgl is not supported by your browser" しかし,WebブラウザはWebGLをサポートはしているのだ。

結局どうすればよいのかということであるが,このパッケージ自体はvue.jsラッパーで大きな内容は書かれていない。
そこで,パッケージ内(node_modules/@statnett/vue-plotly/)Plotly.vueをコピーして手動でimportしてやればよい。
ただし,それではなにも状況が変化しない。
そこで,
import Plotly from 'plotly.js'

import Plotly from 'plotly.js/dist/plotly.min.js'
でおき変える。

これで,この単一ファイルコンポーネントimportすれば使える。

2018/10/02 コンピュータ   TakeMe
< Previous Article     To List     Next Article >

コメント送信フォーム


※ Email will not be published
Loading...
 Please enter the letters of the image